500 HTTP Status error when creating realms in New Experience

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    Applies to:
  • SecureAuth Identity Platform
  • Legacy SecureAuth IdP
Deployment model:
  • Cloud
  • Hybrid
  • On Premises
  • Version Affected:  [22.02+]

    Description:  

    When creating a new realm in the New Experience, a 500 error is thrown. You will see the realm exist in Classic but it does not show up under the Application Manager or Internal Application Manager. You may also notice the Post Auth of the realm in Classic is set incorrectly from what was originally selected.

     

    Cause: 

    There is an issue with the template realm web.config (SecureAuth1) and possibly the Template web.config as well, where something was likely changed that has corrupted the config(s).

     

    Resolution:  

    Follow the steps in this KBA to enable Debug logging for the AdminApiLog file. Look for any errors that may narrow down what is happening during the realm creation. E.g.: 

    2026/04/30 16:49:57.919|Error|SecureAuth.Admin.API.WebApiConfig|[Log] POST|https://localhost/api/v3/applications/|System.InvalidOperationException: Membership Provider LdapMembershipProvider does not exist in configuration.
     

    Back up the existing SecureAuth1 and Template web.config files and navigate to D:\MFCApp_Bin\SISU\Download\Secureauth and in both the SecureAuth1 and Template folders, copy the web.configs over to their respective paths in D:\Secureauth. Afterwards, try creating a realm in the New Experience.

     

    Special Considerations (optional as needed):  

    After Debug logging is no longer needed for the AdminApiLog file, be sure to turn this flag off.

    For any realms that failed to create in the New Experience, you will need to remove their paths from D:\Secureauth and the IIS site as well.

     

     

    SecureAuth Knowledge Base Articles provide information based on specific use cases and may not apply to all appliances or configurations. Be advised that these instructions could cause harm to the environment if not followed correctly or if they do not apply to the current use case.

    Customers are responsible for their own due diligence prior to utilizing this information and agree that SecureAuth is not liable for any issues caused by misconfiguration directly or indirectly related to SecureAuth products.

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