Version Affected: 9.3, 19.07+
Description:
How to enable enhanced logging for the New Experience Admin Console
Cause:
If there are New Experience Admin Console issues, in addition to the nlog from D:\Secureauth\ApplicationApi, it is also possible to enable an additional log.
Resolution:
1. Create this folder if it doesn't yet exist:
D:\Secureauth\AdminApiLogs
2. Backup this file:
D:\Secureauth\Api\nlog.config
3. Edit the file D:\Secureauth\Api\nlog.config and replace the contents with this:
<?xml version="1.0" encoding="utf-8" ?>
<nlog xmlns="http://www.nlog-project.org/schemas/NLog.xsd"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:schemaLocation="http://www.nlog-project.org/schemas/NLog.xsd NLog.xsd"
autoReload="true"
throwExceptions="false"
internalLogLevel="Off" internalLogFile="c:\temp\nlog-internal.log"> <!-- optional, add some variables
https://github.com/nlog/NLog/wiki/Configuration-file#variables
-->
<variable name="myvar" value="myvalue"/> <!--
See https://github.com/nlog/nlog/wiki/Configuration-file
for information on customizing logging rules and outputs.
-->
<targets>
<!--
add your targets here
See https://github.com/nlog/NLog/wiki/Targets for possible targets.
See https://github.com/nlog/NLog/wiki/Layout-Renderers for the possible layout renderers.
--> <!--
Write events to a file with the date in the filename.
<target xsi:type="File" name="f" fileName="${basedir}/logs/${shortdate}.log"
layout="${longdate} ${uppercase:${level}} ${message}" />
-->
<target name="logfile" xsi:type="File" fileName="D:\SecureAuth\AdminApiLogs\AdminApiLog.txt"
layout="${date:universalTime=True}|${level}|${logger}|${message}|${exception:format=tostring}"/>
</targets> <rules>
<!-- add your logging rules here --> <!--
Write all events with minimal level of Debug (So Debug, Info, Warn, Error and Fatal, but not Trace) to "f"
<logger name="*" minlevel="Debug" writeTo="f" />
-->
<logger name="*" minlevel="Debug" writeTo="logfile" />
</rules>
</nlog>
4. The new log will appear as D:\SecureAuth\AdminApiLogs\AdminApiLog.txt.
5. When troubleshooting both the above file and the file D:\SecureAuth\ApplicationApi\nlog-all-YYYY-MM-DD.log should be used in conjunction and supplied together if requested by SecureAuth Technical Support.
SecureAuth Knowledge Base Articles provide information based on specific use cases and may not apply to all appliances or configurations. Be advised that these instructions could cause harm to the environment if not followed correctly or if they do not apply to the current use case.
Customers are responsible for their own due diligence prior to utilizing this information and agree that SecureAuth is not liable for any issues caused by misconfiguration directly or indirectly related to SecureAuth products.
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