404 when trying to use URL enrollment

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    Applies to:
  • SecureAuth Identity Platform
  • Legacy SecureAuth IdP
Deployment model:
  • Cloud
  • Hybrid
  • On Premises
  • Version Affected:  SecureAuth Identity Platform all versions

    Description:  

    When trying to use URL enrollment on the Authenticate app or the Passcode app, it errors out with a 404 - File or directory not found.

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    Cause:  

    The Authenticate app and the Passcode app is hardcoded to add the SecureAuth998 at the end of the FQDN if it does not detect a SecureAuth realm number.  This usually would happen if you are using a vanity URL or alias for the realm.  

    For example, if a user types in the FQDN and the alias, the application will try and redirect to https://FQDN.com/Enroll/SecureAuth998.

    Resolution:

    Do not use the alias when using URL enrollment, and have users type in the FQDN.  This will redirect them to SecureAuth998, which by default is set to use URL enrollment. 

     

     

    SecureAuth Knowledge Base Articles provide information based on specific use cases and may not apply to all appliances or configurations. Be advised that these instructions could cause harm to the environment if not followed correctly or if they do not apply to the current use case.

    Customers are responsible for their own due diligence prior to utilizing this information and agree that SecureAuth is not liable for any issues caused by misconfiguration directly or indirectly related to SecureAuth products.

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