Access to Key File is Denied Application Pool Error

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    Applies to:
  • Legacy SecureAuth IdP
Deployment model:
  • Hybrid
  • On Premises
  • Version Affected:  9.2 and Below

    Description:  

    Error logs display this message:

    [LicenseHandler].[SetLicenseKey] Exception: System.UnauthorizedAccessException: Access to the path 'D:\SecureAuth\key.file' is denied.

     

    Cause:  

    The Application Pool that the realm is in is trying to access the license key because it has been at least a month or two since it was last updated. However, it does not have the correct permissions to make the change.

    When an Application Pool is created by an administrator, it defaults to the Identity of ApplicationPoolIdentity, which is not the same Identity as the .NET v4.5 Application Pool.

     

    Resolution:  

    Check to make sure that the Application Pools that contain any SecureAuth realms (except SecureAuth0) are set to the correct Identity of Network Service.

     

     

    SecureAuth Knowledge Base Articles provide information based on specific use cases and may not apply to all appliances or configurations. Be advised that these instructions could cause harm to the environment if not followed correctly or if they do not apply to the current use case.

    Customers are responsible for their own due diligence prior to utilizing this information and agree that SecureAuth is not liable for any issues caused by misconfiguration directly or indirectly related to SecureAuth products.

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