Workcloud rejecting SAML assertion

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    Applies to:
  • SecureAuth Identity Platform
  • Legacy SecureAuth IdP
Deployment model:
  • Cloud
  • Hybrid
  • On Premises
  • Version Affected:  All

    Description:  

     

    Workcloud rejects SAML if it has the following line in the SAML assertion

    <saml:AttributeStatement />

     

    Cause:  

    <saml:AttributeStatement /> is sent when there are no claims currently specified but previously a static claim was set. 

    This can be because it was set on a realm that you've cloned.

     

    Resolution:  

    There are two workarounds for this.

    Either 1, Add a claim so the AttributeStatement isn't blank

    or

    2,  Edit the Web.config to set the <add key="ExtendedSAMLAttrCount" value="1" /> to 0

     

    Steps for option 2.

     

    • Take a copy of D:\SecureAuth\SecureAuthxyz\web.config
    • In the Admin Console, go to Advanced Settings
    • Click Tools | Decrypt web.config
    • Open the web.config and search for ExtendedSAMLAttrCount"
    • Set the value to 0
    • Save it and try again

     

     

     

     

    SecureAuth Knowledge Base Articles provide information based on specific use cases and may not apply to all appliances or configurations. Be advised that these instructions could cause harm to the environment if not followed correctly or if they do not apply to the current use case.

    Customers are responsible for their own due diligence prior to utilizing this information and agree that SecureAuth is not liable for any issues caused by misconfiguration directly or indirectly related to SecureAuth products.

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