Push Notification not working for some users

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    Applies to:
  • SecureAuth Identity Platform
  • Legacy SecureAuth IdP
Deployment model:
  • Cloud
  • Hybrid
  • On Premises
  • Version Affected:  21.04 onwards

    Description:  

    Push Notification not working for some users.

    In the logs, you see

    Message=""Mobile Service SendPushNotification, StatusCode: BadGateway. ResponseTime='155'"""

     

    Cause:  

    Although the message "Bad Gateway" implies a communication error, the real error has been masked by the time it reaches the log. 

    The real cause of this is Users not allowing Push Notification on the Authenticate App. 
    If Push Notification is disabled when they enrol, the enrollment completes for TOTP but some details we need to be able to send Push to their device is not available during the enrollment, so push will never work. 

    Even if the User enables Push at a later date, the details are still missing without a re-enroll.

     

    Resolution:  

    1. Enable Push Notifications for the Authenticate App
    2. Remove the current enrolment
    3. Re-enrol

     

    Special Considerations:  

    SecureAuth we be releasing an update for MobileSVC so if the User has enrolled without Push enabled, they will not be offered Push as an option.

     

     

    SecureAuth Knowledge Base Articles provide information based on specific use cases and may not apply to all appliances or configurations. Be advised that these instructions could cause harm to the environment if not followed correctly or if they do not apply to the current use case.

    Customers are responsible for their own due diligence prior to utilizing this information and agree that SecureAuth is not liable for any issues caused by misconfiguration directly or indirectly related to SecureAuth products.

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