RADIUS: A notification is in progress

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    Applies to:
  • SecureAuth Identity Platform
  • Legacy SecureAuth IdP
Deployment model:
  • Cloud
  • Hybrid
  • On Premises
  • Version Affected:  RADIUS

    Description:  

    When trying to login multiple times to RADIUS, the User sees a message "A notification is in progress. You can accept it and enter N or request a new one by entering Y"

     

    Cause:  

    The user quit the authentication process mid login after a Push Notification had been sent but not accepted or rejected and the background process to check the status of the push is still running when they start a new login attempt.

     

    Resolution:  

    If you don't wish the User to see the above prompt, we can hide it with a setting in the RADIUS properties file. This settings Boolean value appears somewhat backwards, so do follow this KB

    1. Navigate to C:\Program Files\SecureAuth Corporation\SecureAuth IdP RADIUS Agent\bin\conf
    2.  Open appliance.radius.properties file
    3. Add the value


      offer_discard_current_push_authentication_request=true

    4.  Save the file
    5. Restart the Radius Service

     

    By default, this property is set to false, when false it will prompt the user to discard the P2A before sending a new one.

    When set to true, it will not prompt the user to discard the P2A and send a new one every time.

     

     

     

    SecureAuth Knowledge Base Articles provide information based on specific use cases and may not apply to all appliances or configurations. Be advised that these instructions could cause harm to the environment if not followed correctly or if they do not apply to the current use case.

    Customers are responsible for their own due diligence prior to utilizing this information and agree that SecureAuth is not liable for any issues caused by misconfiguration directly or indirectly related to SecureAuth products.

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