Sub is not showing the selected attribute in Access Token

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    Applies to:
  • Cloudentity
Deployment model:
  • Cloud
  • Version Affected:  All

    Description:  

    In the audit logs the email looks like a mapped to sub but the email is missing in the returned token. In the field "sub" there is another value instead of the email.

     

    Cause:  

    Sub is mapped differently to other attributes.

     

    Resolution:  

     

    1. In the Workspace, click Oauth | Tokens
    2. Click Subject Identifier
    3. Select Custom for the subject format
    4. Set the Custom Subject Attribute to Email
    5. Save the changes
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    SecureAuth Knowledge Base Articles provide information based on specific use cases and may not apply to all appliances or configurations. Be advised that these instructions could cause harm to the environment if not followed correctly or if they do not apply to the current use case.

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