Version Affected: 20.06+
Description:
Each customer have their own FIDO2 cloud tenant for which enrollments are securely saved. Upon attempting to enroll, the end-user presses the 'Register' button but is then is presented with the error "There has been an error."
Cause:
With the error being "502 Bad Gateway", this usually means there is something wrong with the FIDO2 cloud tenant.
Resolution:
Enable Debug logging on the FIDO2 enrollment realm and look in the log file (debug.log), look for the "502 Bad Gateway" message as such:
LogChannel="SA_DEBUG" FormatVersion="0.0.1" EventID="70011" Timestamp="2022-02-10T23:05:45.804Z" CompanyID="" ApplianceID="" Realm="" UserID="" BrowserSession="xxxxx-xxxxx-xxxxx-xxxxx-xxxxxx" StateMachineID="" RequestID="xxxxx-xxxxx-xxxxx-xxxxx-xxxxxx" UserHostAddress="" Message="Fido2Helper.BeginEnroll != IsSuccessStatusCode - - <html>
<head><title>502 Bad Gateway</title></head>
<body>
<center><h1>502 Bad Gateway</h1></center>
<hr><center>openresty/1.15.8.2</center>
</body>
</html>
- Reason: Bad Gateway - statusCode: BadGateway"
Contact support so we can engage our Cloud Team to resolve the issue.
Special Considerations (optional as needed):
The support team can use our internal testing tool with the verbose option to see the same or similar error:
SecureAuth Knowledge Base Articles provide information based on specific use cases and may not apply to all appliances or configurations. Be advised that these instructions could cause harm to the environment if not followed correctly or if they do not apply to the current use case.
Customers are responsible for their own due diligence prior to utilizing this information and agree that SecureAuth is not liable for any issues caused by misconfiguration directly or indirectly related to SecureAuth products.
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