Logging to the SecureAuth SQL logging database stops

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    Applies to:
  • SecureAuth Identity Platform
  • Legacy SecureAuth IdP
Deployment model:
  • Cloud
  • Hybrid
  • On Premises
  • Version Affected:  All

    Description:  

    When using the SQL Logging database, administrators may see times when logging stops without any proper error messaging.

     

    Cause:  

    This issue is caused by NULL values being sent to the Microsoft Logging library by the SecureAuth IdP.

     

    Resolution:  

    A hotfix will be provided for this issue. Please watch for issue EE-2469 in the hotfix release notes.

    As a temporary fix, you can remove the formatter for the DB Trace Listener in the web.config file for each realm using SQL logging. To do so:

    One thing to watch when doing the above procedure is that the formatting of the logs within the database will not be the same as with it enabled. If possible, wait for the hotfix to be released and apply it for a proper resolution to the issue.

    1. Decrypt the web.config file via the System Info tab or by using the Decrypt web.config menu item in the classic admin area
    2. Find the line:
      <add name="DatabaseTraceListner" type="MFC.SecureAuth.Logging.FormattedDatabaseTraceListener, MFC.SecureAuth.Logging" listenerDataType="MFC.SecureAuth.Logging.FormattedDatabaseTraceListenerData, MFC.SecureAuth.Logging" databaseInstanceName="LogDatabase" writeLogStoredProcName="WriteLog" addCategoryStoredProcName="AddCategory" formatter="Text Formatter" />
    3. Remove the end formatter bit:
      formatter="Text Formatter"
    4. the web.config line should look like this after the change:
      <add name="DatabaseTraceListner" type="MFC.SecureAuth.Logging.FormattedDatabaseTraceListener, MFC.SecureAuth.Logging" listenerDataType="MFC.SecureAuth.Logging.FormattedDatabaseTraceListenerData, MFC.SecureAuth.Logging" databaseInstanceName="LogDatabase" writeLogStoredProcName="WriteLog" addCategoryStoredProcName="AddCategory" />

     

     

     

    SecureAuth Knowledge Base Articles provide information based on specific use cases and may not apply to all appliances or configurations. Be advised that these instructions could cause harm to the environment if not followed correctly or if they do not apply to the current use case.

    Customers are responsible for their own due diligence prior to utilizing this information and agree that SecureAuth is not liable for any issues caused by misconfiguration directly or indirectly related to SecureAuth products.

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