FileBeat Error "Could not find a suitable client certificate in the certificate store."

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    Applies to:
  • SecureAuth Identity Platform
Deployment model:
  • Hybrid
  • Version Affected: All

    Description:  

    An error that comes up when updating or installing SecureAuth FileBeat.

     

    Cause:  

    FileBeat is unable to find a suitable client due to the first SecureAuth certificate down the verifystore list showing up as an expired or older cert. It should be using a certificate with an X1/X2 intermediate certificate.

     

    Resolution:  

    1. Run "certutil -verifystore my" in command prompt in order to see the order of your certificate list.
    2. Look for the first SecureAuth certificate listed, which should confirm that an older one is listed before one that does have the appropriate X1/X2 intermediate.
    3. Check Certificates Console to make sure you have the X1/X2 intermediate certificates installed on the server.
    4. Change the directory to your FileBeat installer location.
    5. Run "filebeat.msi MARVIN_CERT_ISSUER_STRINGS=X1"

     

    SecureAuth Knowledge Base Articles provide information based on specific use cases and may not apply to all appliances or configurations. Be advised that these instructions could cause harm to the environment if not followed correctly or if they do not apply to the current use case.

    Customers are responsible for their own due diligence prior to utilizing this information and agree that SecureAuth is not liable for any issues caused by misconfiguration directly or indirectly related to SecureAuth products.

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