Version Affected: 24.4.7
Description:
After upgrading to 24.4.7, Datastore(s) will not open and will throw a 500 error in DevTools
Looking at the API Logs, an exception similar to the below can be seen
2025/11/19 21:31:21.476|Error|SecureAuth.Admin.API.WebApiConfig|[Log] GET|https://localhost/api/v3/data_stores/ac123b45-67c8-9101-1213-1415cf5be83e|System.NullReferenceException: Object reference not set to an instance of an object.
at SecureAuth.Integration.Broker.Models.DataStoreConfigBase.MaskCredentials()
Cause:
Looking at the error message, we can see it is failing on a MaskCredentials call
This happens due to the Datastore not holding any credentials/password for the Service Account field, the MaskCredentials function is expecting a value, when it does not find one a NULL Reference is thrown
Resolution:
The resolution involves one of the below options:
- Accessing the Datastore Summary from an IdP Appliance on an earlier version and entering some Service Account Credentials/Password, even if they are invalid credentials
- Deleting the Datastore and recreating it
If it is not possible to delete the Datastore and you are not able to access it on an earlier version of IdP, please contact SecureAuth Support who will be able to help
SecureAuth Knowledge Base Articles provide information based on specific use cases and may not apply to all appliances or configurations. Be advised that these instructions could cause harm to the environment if not followed correctly or if they do not apply to the current use case.
Customers are responsible for their own due diligence prior to utilizing this information and agree that SecureAuth is not liable for any issues caused by misconfiguration directly or indirectly related to SecureAuth products.
Comments
Article is closed for comments.