Version Affected: All
Description:
HTTP Error 500.19 can be thrown for any number of reasons but it usually comes down to an inability to read a web.config for one reason or another, it will be accompanied with the below message
The requested page cannot be accessed because the related configuration data for the page is invalid
This article specifically covers the error code of 0x8007000d
Cause:
500.19 - 0x8007000d is usually thrown when there is a problem with .NET (Core) or a .NET Module
Each version of IdP has a requirement for .NET Core, or .NET in later versions, to be installed on the IdP Servers, without it installed, there will be problems seen with IdP
The 0x8007000d error has been caused in the past by .NET (Core) not being installed but the much more common reason this error is seen is due to an earlier version of .NET (Core) being uninstalled after a newer version has been installed.
When uninstalling a version of .NET (Core), it can uninstall parts of .NET (Core) which other versions being left on the Server require to run correctly.
This can leave the the Server in a state which looks as though it is setup correctly but actually has problems in the background.
Resolution:
See the following for the compatible versions of .NET (Core) for each version of IdP - https://docs.secureauth.com/2404/en/secureauth-compatibility-guide.html#required--net-versions
If a compatible version of .NET (Core) is already installed on the system, the first recommendation is to run a 'Repair' against each part of that version via 'Add/Remove Programs'
Run a repair against each .NET (Core) module and once complete, test Identity Platform again to see if it has rectified the error(s)
If an incompatible version of .NET (Core) is installed, it is recommended to uninstall all parts of that version of .NET (Core), then install a compatible version after
It is important to install the compatible version AFTER uninstalling the incompatible version
To download .NET (Core), please see the following link - https://dotnet.microsoft.com/en-us/download/dotnet
SecureAuth Knowledge Base Articles provide information based on specific use cases and may not apply to all appliances or configurations. Be advised that these instructions could cause harm to the environment if not followed correctly or if they do not apply to the current use case.
Customers are responsible for their own due diligence prior to utilizing this information and agree that SecureAuth is not liable for any issues caused by misconfiguration directly or indirectly related to SecureAuth products.
Comments
Please sign in to leave a comment.