Invalid TOTP error after changing Search Filter

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    Applies to:
  • SecureAuth Identity Platform
  • Legacy SecureAuth IdP
Deployment model:
  • Cloud
  • Hybrid
  • On Premises
  • Version Affected:  Prior to 21.04

    Description:  

    After changing the Search Filter on the datatab, TOTP is still presented as an MFA option but TOTP is showing as invalid for anyone who tries to use it

     

    Cause:  

    The search filter needs to include the Search Attribute that you have set.

     

    Resolution:  

    If, for example, you want to allow the users to login with mail, your Search Filter would be

    (&(mail=%v)(objectclass=user))

    However, if your SearchAttribute is set to SamAccountName, you'll need to make sure that SamAccountName is also allowed. 

     

    For example,

    (&(|(samAccountName=%v)(mail=%v))(objectclass=user))

     

    SecureAuth Knowledge Base Articles provide information based on specific use cases and may not apply to all appliances or configurations. Be advised that these instructions could cause harm to the environment if not followed correctly or if they do not apply to the current use case.

    Customers are responsible for their own due diligence prior to utilizing this information and agree that SecureAuth is not liable for any issues caused by misconfiguration directly or indirectly related to SecureAuth products.

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