20.06 Login Delay when IdP is behind a proxy

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    Applies to:
  • SecureAuth Identity Platform
Deployment model:
  • Hybrid
  • Version Affected:  20.06

    Description:  

    When attempting to Login to a realm, there is a long delay before the User is successfully authenticated. This can be between 10 seconds to 1 minute. 

    The debug log shows

     

    BrowserSession="" StateMachineID="" RequestID="" UserHostAddress="" Message="Fido2Manager.GetTokens - System.AggregateException: One or more errors occurred. ---> System.Net.Http.HttpRequestException: An error occurred while sending the request. ---> System.Net.WebException: Unable to connect to the remote server ---> System.Net.Sockets.SocketException: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond

    Cause:  

    We are not honouring your Proxy settings for our Fido call and so this call needs to timeout before we proceed to the next step. 

     

    Resolution:  

    Whilst we wait to release a hotfix, you can add your Proxy settings to the Web.config to work around this issue. 

     

    1. Decrypt the Web.config
    2. Take a back up of D:\Secureauth\SecureAuthx\web.config
    3. Edit D:\Secureauth\SecureAuthx\web.config
    4. Search for <system.net> and add the following (Don't copy and paste from here as you'll get special characters which will break your web.config) 


        <defaultProxy>
          <proxy
            proxyaddress="http://12.34.56.78:8080"
            bypassonlocal="true"
          />
        </defaultProxy>

     


    mceclip0.png

    5. Don't forget to adjust the Proxy Address and Port for your Proxy.

    6. Save the web.config file.

     

    Special Considerations:  

    This is logged with the Dev team. 

     

     

    SecureAuth Knowledge Base Articles provide information based on specific use cases and may not apply to all appliances or configurations. Be advised that these instructions could cause harm to the environment if not followed correctly or if they do not apply to the current use case.

    Customers are responsible for their own due diligence prior to utilizing this information and agree that SecureAuth is not liable for any issues caused by misconfiguration directly or indirectly related to SecureAuth products.

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