Version Affected: ALL
Description:
When attempting to launch the SecureAuthUpdater.exe, the updater never launches.
Running the updater via an Administrative Command Prompt or PowerShell with a command-line option will give the error:
PS D:\SecureAuth-Update\> .\SecureAuthUpdater.exe -autorun
PS D:\SecureAuth-Update\> Unhandled exception caught: The type initializer for 'SecureAuthUpdater.ApplianceManager' threw an exception., stacktrace: at SecureAuthUpdater.ApplianceManager.ListAllRealmPaths()
at SecureAuthUpdater.Program.RunMain(String[] args)
at SecureAuthUpdater.Program.Main(String[] args)
Process is exiting with result code: 1
Cause:
The current iteration of the SecureAuth Updater requires SecureAuth0 and SecureAuth1 to exist in the D:\SecureAuth folder on the server. It also requires that the SecureAuth1 \bin\ folder of each contains the MFC.SecureAuth.License.dll file.
Resolution:
Check D:\SecureAuth for folders SecureAuth0 and SecureAuth1.
If these folders exist, check for the MFC.SecureAuth.License.dll file in \SecureAuth1\bin\ folder.
If the realm folder does not exist, creating a new realm should re-create the folder structure.
If the folder exists but the file does not, copying the file in the \bin\ folder will resolve the issue.
Special Considerations (optional as needed):
If the realm does not get created properly, a support engineer will be able to assist in the proper creation of the realm manually.
SecureAuth Knowledge Base Articles provide information based on specific use cases and may not apply to all appliances or configurations. Be advised that these instructions could cause harm to the environment if not followed correctly or if they do not apply to the current use case.
Customers are responsible for their own due diligence prior to utilizing this information and agree that SecureAuth is not liable for any issues caused by misconfiguration directly or indirectly related to SecureAuth products.
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