Lucity SAML integration not working

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    Applies to:
  • SecureAuth Identity Platform
  • Legacy SecureAuth IdP
Deployment model:
  • Cloud
  • Hybrid
  • On Premises
  • Version Affected:  All

    Description:  

    Trying to integrate Lucity using SAML SP Initiated by Redirect and it's not working. 

    9.3+ shows a blank white screen after logging into SecureAuth. 

    Older than 9.3 shows an error message "Failed to receive SAML.." 

    Cause:  

    Lucity is not correctly formatting the SAML AuthN request. 

    Resolution:  

    Lucity have created a Patch to fix this issue. 

    We require the AuthN request to be deflated, base64encoded and can also work if it is URL encoded in addition to deflated and base64encoded.

    Your Lucity rep should be able to get the updated Lucity version to you. 

     

     

    SecureAuth Knowledge Base Articles provide information based on specific use cases and may not apply to all appliances or configurations. Be advised that these instructions could cause harm to the environment if not followed correctly or if they do not apply to the current use case.

    Customers are responsible for their own due diligence prior to utilizing this information and agree that SecureAuth is not liable for any issues caused by misconfiguration directly or indirectly related to SecureAuth products.

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