SecureAuth /admin/ endpoint is visible by default

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    Applies to:
  • SecureAuth Identity Platform
  • Legacy SecureAuth IdP
Deployment model:
  • Hybrid
  • On Premises
  • Version Affected:  all

    Description:  

    The /admin/ endpoint is exposed by default on current IdP servers.

    The realms.json file may be interesting but upon review the data is not valid for any configured appliance.

     

    Cause:  

    This is a default configuration. Said endpoint only contains template data and no actual data from a configured IdP server.

     

    Resolution:  

    This endpoint can be blocked via IP Address restrictions or by using an IIS Rewrite rule to disallow any access/browsing of the /Admin endpoint.

    The easiest option is to use URL rewrite.

     

    1. Open up IIS Manager

    2. Navigate down through Sites | Default Web Site | to the Admin site

    3. Double click URL Rewrite

    4. Click Add Rule(s)...

    5. Select Request blocking and click OK

    6. Set Block access based on IP address

    7. Block request that does NOT match the pattern

    8. Set the Pattern to 127.0.0.1

    9. Click OK

     

     

    Special Considerations:  

    See article Create a Redirect from any Realm to a new Realm for information on creating a redirect within the IIS Manager on the SecureAuth IdP for a way to remedy this.

     

    SecureAuth Knowledge Base Articles provide information based on specific use cases and may not apply to all appliances or configurations. Be advised that these instructions could cause harm to the environment if not followed correctly or if they do not apply to the current use case.

    Customers are responsible for their own due diligence prior to utilizing this information and agree that SecureAuth is not liable for any issues caused by misconfiguration directly or indirectly related to SecureAuth products.

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