Data stores cannot be saved in the new experience when IdP is behind a proxy

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    Applies to:
  • Legacy SecureAuth IdP
Deployment model:
  • On Premises
  • SecureAuth Idp Version affected:  9.3.0 - hotfix 9.3.0-2

    Description: 

    After following this article: https://support.secureauth.com/hc/en-us/articles/360025663992-IdP-admin-console-will-not-open-and-displays-a-blank-screen-in-environments-that-use-a-Proxy it's possible to open the Admin console but Data store connections will not save. 

    Additionally a network trace will show that the ApplicationAPI does not honor the Proxy settings and always attempts a direct connection instead, failing with this error in the .NLOG file (nlog-all-YYYY-MM-DD.log):

    ERROR|IdP.Application.API.Controllers.ErrorController|[Error] Error at /v1/data_stores. Exception: System.AggregateException: One or more errors occurred. (A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond) ---> System.Net.Http.HttpRequestException: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond ---> System.Net.Sockets.SocketException: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond

     

    In addition to this Cloud Transport, FileBeat and Metric Beat services all try to do direct connections to the internet, rather than using the proxy. 

     

    Cause:  

    Product Defect EE-1089

     

    Resolution: 

    Fixed in Hotfix 9.3.0-3

    Please contact Product Support to obtain the hotfix.

     

    To install the hotfix:

    1. Take a snapshot or backup of the IdP
    2. Download to the IdP
    3. Right click the ZIP | Properties | Click "Unblock" (if present)
    4. Extract to a folder of your choice on the D: drive
    5. Run as Administrator and choose to update all realms when asked.
    6. Once the hotfix has installed the proxy settings of both the Analyze API and Application API can be managed by editing the proxy settings on the System Info tab of realm 0. 

     

    SecureAuth Knowledge Base Articles provide information based on specific use cases and may not apply to all appliances or configurations. Be advised that these instructions could cause harm to the environment if not followed correctly or if they do not apply to the current use case.

    Customers are responsible for their own due diligence prior to utilizing this information and agree that SecureAuth is not liable for any issues caused by misconfiguration directly or indirectly related to SecureAuth products.

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