Credential Provider troubleshooting

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    Applies to:
  • Legacy SecureAuth IdP
Deployment model:
  • On Premises
  • SecureAuth IdP Version affected: All
     
    Description: 
    When attempting to set up the Credential Provider for the first time, Users cannot login with their OTP
     
    Cause:
    Communication issues with the OTP Webservice 

    Eg, https://secureauth.Example.local/secureauth998/webservice/profilews.svc


    Resolution:
     
    Turn on Credential Provider logging to see where the issue is

    1. On the affected machine, open Regedit

    2. Navigate to HKLM\Software\SecureAuth2FactorCP

    3. Create/Edit a String value called OTPLog and set this to 1

    4. Create/Edit a String value called otpLogPath and set this to a safe location such as C:\Temp

    5. Reproduce the problem.

    6. Check the logs. 

     

    If the logs hint that the issue is talking to the url, try going to the same URL in a browser from that machine.

    If you see "An Authentication error has occurred" it means that you are seeing our friendly custom error page and should turn this off to view the real problem.

    6. Open up the SecureAuth Admin console

    7. Open the Logs tab for the affected Realm

    8. Set Custom Errors to off

    9. Back on the Credential Provider machine, use the Browser to view the URL again. Now you should see the real error.

     

    SecureAuth Knowledge Base Articles provide information based on specific use cases and may not apply to all appliances or configurations. Be advised that these instructions could cause harm to the environment if not followed correctly or if they do not apply to the current use case.
    Customers are responsible for their own due diligence prior to utilizing this information and agree that SecureAuth is not liable for any issues caused by misconfiguration directly or indirectly related to SecureAuth products

     

     

     

     

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