SecureAuth IdP Version Affected: All
Description:
When attempting to save a realm in the Admin Console, even without any changes made to it, you could receive an error in authentication. This error could be caused by the incorrect permissions that are not allowing SecureAuth0 to make changes to the realm. These faulty permissions will throw you "An Error in the authentication has occurred. Please Try Again. If the error persists, please contact your administrator."
Cause:
The likely reason for this issue is that the SecureAuth0Pool is has not been added or does not have the correct permissions in this realm. SecureAuth0Pool is used so that SecureAuth0 can make changes to a realm as it is the admin realm.
Resolution:
This can be corrected by adding SecureAuth0Pool in with the Reset-File-Perms.bat tool or manually in IIS.
To correct this automatically:
Follow this document
https://docs.secureauth.com/display/SAT/Using+the+Reset+File+Permissions+and+Shares+Tool
OR
To correct this manually:
1. Go to your IIS Manager in the IdP Server
2. Right click the realm and go to Edit Permissions
3. Go to Security tab and click on Edit
4. Change the location to your Local Appliance and enter the object name "IIS AppPool\SecureAuth0Pool"
5. Check the name and press OK
Be sure that SecureAuth0Pool has Write/Modify Permissions
Congrats! You have added SecureAuth0Pool back into your IIS Realm Permissions. You should be able to save to your Realm now in the Admin Console.
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