"Error Retrieving Contact Information" when using OpenLDAP

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    Applies to:
  • Legacy SecureAuth IdP
Deployment model:
  • On Premises
  • SecureAuth version affected: All
    Description:

    When attempting to Login to a realm that is configured to use OpenLDAP, the user sees the error "Error Retrieving Contact Information" and they cannot proceed.

     

    Cause:

    An issue with the connection string for the ProfileProvider prevents SecureAuth from retrieving the Users properties

     

    Workaround:

    1. Change the ProfileProvider to “Same as above” = False
    2. Set the Directory Server as “AD-LDS” (even though you are really still using OpenLDAP)
    3. Fill in the rest of the details exactly the same as your OpenLDAP Membership Connection Settings
    4. Save settings and test

    Status:

    Waiting to be fixed in a future release of SecureAuth

     

    SecureAuth Knowledge Base Articles provide information based on specific use cases and may not apply to all appliances or configurations. Be advised that these instructions could cause harm to the environment if not followed correctly or if they do not apply to the current use case.
    Customers are responsible for their own due diligence prior to utilizing this information and agree that SecureAuth is not liable for any issues caused by misconfiguration directly or indirectly related to SecureAuth products

     

     

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