Client ID cannot be modified or removed after being created

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    Applies to:
  • SecureAuth Identity Platform
  • Legacy SecureAuth IdP
Deployment model:
  • Cloud
  • Hybrid
  • On Premises
  • Version Affected:  [All]

    Description:  

    When creating a Client ID in an OpenID realm, if a name is not initially entered, you will see the following:

     

    Cause:  

    Since there was no name initially entered, there is no link that takes the admin to the client itself to either modify or remove.

     

    Resolution:  

    Decrypt the web.config and search for the Client ID value and remove this section. Prior to doing so, it is ideal to take a backup of the existing web.config. If you are a Cloud customer, please open a ticket with Support regarding this.

    This has been reported as a bug in SAIDP-882.

     

    SecureAuth Knowledge Base Articles provide information based on specific use cases and may not apply to all appliances or configurations. Be advised that these instructions could cause harm to the environment if not followed correctly or if they do not apply to the current use case.

    Customers are responsible for their own due diligence prior to utilizing this information and agree that SecureAuth is not liable for any issues caused by misconfiguration directly or indirectly related to SecureAuth products.

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