Exception message: An item with the same key has already been added.

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    Applies to:
  • SecureAuth Identity Platform
Deployment model:
  • Hybrid
  • Version Affected:  All

    Description:  

    When accessing the Advanced/Classic Experience, the page throws a generic "Please Contact Your Administrator" error if custom errors are turned on.

     

    Error and Event logs throw an "Exception message: An item with the same key has already been added."

     

    Cause:  

    Same realms are being referenced due to duplication in the folders and possibly in IIS.

     

    Resolution:  

    1. Go through your realms in D:\SecureAuth

    2. Find any realms with beginning duplicate SecureAuth# format

    3. Move/Remove them from the folder and remove them from IIS as well if they are present.

    Example:

    SecureAuth24
    SecureAuth25
    SecureAuth25_ORG
    SecureAuth25_ORG1
    SecureAuth25_ORG2
    SecureAuth26

    In this case, the duplicates would be SecureAuth25_ORG, SecureAuth25_ORG1, and SecureAuth25_ORG2. Keeping a copy of these temporarily would be recommended in-case they need to be recovered for whatever reason.

     

    SecureAuth Knowledge Base Articles provide information based on specific use cases and may not apply to all appliances or configurations. Be advised that these instructions could cause harm to the environment if not followed correctly or if they do not apply to the current use case.

    Customers are responsible for their own due diligence prior to utilizing this information and agree that SecureAuth is not liable for any issues caused by misconfiguration directly or indirectly related to SecureAuth products.

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