Web Service realms timing out after 5 seconds

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    Applies to:
  • SecureAuth Identity Platform
  • Legacy SecureAuth IdP
Deployment model:
  • Cloud
  • Hybrid
  • On Premises
  • Version Affected:  All

    Description:  

    End users may receive the error message 'Error Retrieving Contact Information' and when the admin views the Warning log for the realm having said issue, it shows the error 'Message="WebServiceProfileProvider.GetPropertyValuesBase: Getting user 'USERNAME' profile got exception: System.TimeoutException: The request channel timed out while waiting for a reply after 00:00:05. Increase the timeout value passed to the call to Request or increase the SendTimeout value on the Binding. The time allotted to this operation may have been a portion of a longer timeout. ---> System.TimeoutException: The HTTP request to 'https://localhost/SecureauthXXX/webservice/profilews.svc' has exceeded the allotted timeout of 00:00:05. The time allotted to this operation may have been a portion of a longer timeout. ---> System.Net.WebException: The operation has timed out'.

     

    Cause:  

    There is some issue with receiving the data from the Datastore or Profile store. The issue could be a busy server, networking issue, etc

     

    Resolution:  

    The timeout can be increased via the web.config file.

    Please note, this should be done on both the "webservice" client realm (eg, The DMZ server) and the Webservice server realm (eg, the Internal server) 

    Decrypt the web.config for the realm having the issue and edit it in your favourite Text editor (Notepad, NotePad++, PSPad, EmEditor, etc)

    In the <appSettings> area, add the following:

    <add key="WCFBindingSendTimeout" value="10" /> 
    <add key="WCFBindingReceiveTimeout" value="10" /> 
    <add key="WCFBindingOpenTimeout" value="10" /> 
    <add key="WCFBindingCloseTimeout" value="10" />

    The value in the above is in Seconds. The default value for Web Services is 5 seconds.

     

    SecureAuth Knowledge Base Articles provide information based on specific use cases and may not apply to all appliances or configurations. Be advised that these instructions could cause harm to the environment if not followed correctly or if they do not apply to the current use case.

    Customers are responsible for their own due diligence prior to utilizing this information and agree that SecureAuth is not liable for any issues caused by misconfiguration directly or indirectly related to SecureAuth products.

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