Version Affected: 21.04+
Description:
Password Reset Notification emails are formatted correctly as HTML within Content and Localization settings for the passwordreset_emailbody value (see below as an example), but the emails are still sent to the end users as Plain Text, including all the HTML tags
<br><br>Your password for your account was recently changed.<br>If you made this change, no further action is required.<br><br>If you did not make this change, please contact the Service Desk immediately.<br><br>Thank you,<br>Need help? Contact Service Desk<br>Phone: 1-800-123-4567<br>Email: servicedesk@company.com<br>
Cause:
This is caused by a product bug, the only configuration where Password Reset Notification Emails are sent out correctly as HTML is:
Classic Realm Configuration
Must ONLY have Password Reset Notification Email in HTML set to ‘One-Time Passcode via HTML’
New Experience (SWAP)
Must ONLY have ‘One-time passcode’ selected as the email MFA option in the Policy (and have HTML selected at the Global MFA - Email' level
When ANY other options are enabled, either on their own or in addition to the above configuration, Password Reset Notification Emails will be sent out in Plain Text
Resolution:
This issue has been fixed in 24.4.3
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Customers are responsible for their own due diligence prior to utilizing this information and agree that SecureAuth is not liable for any issues caused by misconfiguration directly or indirectly related to SecureAuth products.
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