Version Affected: All
Description:
When using the Import API, it throws a 422 error, along with some text explaining what the issue is.
https://{{tenantID}}.{{region}}.authz.cloudentity.io/api/system/{{tenantID}}/configuration?mode=update
For example:
{
"status_code": 422,
"error_code": "",
"error": "OAuth client wants to use authorization_code grant type but authorization server does not allow it",
"details": null
}
Cause:
The configuration you're trying to import is mis-configured.
Resolution:
Edit the JSON that you're using for the import to correct the misconfiguration and then the import will work correctly.
The import tool checks the Workspace configuration and will only import clients that are compatible with those settings.
SecureAuth Knowledge Base Articles provide information based on specific use cases and may not apply to all appliances or configurations. Be advised that these instructions could cause harm to the environment if not followed correctly or if they do not apply to the current use case.
Customers are responsible for their own due diligence prior to utilizing this information and agree that SecureAuth is not liable for any issues caused by misconfiguration directly or indirectly related to SecureAuth products.
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