HowTo: Create a SAML Trace

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    Applies to:
  • SecureAuth Identity Platform
  • Legacy SecureAuth IdP
Deployment model:
  • Cloud
  • Hybrid
  • On Premises
  • Version Affected:  All

    Description:  

    When implementing SAML applications, the Support Team may ask for a SAML trace. This article will show how to install SAML-tracer and take a SAML Trace which the Support Team will be able to view to debug the issue at hand.

     

    Cause:  

    SAML debugging may be required during a new implementation/integration with the SecureAuth Workforce platform.

     

    Resolution:  

    1. Install the SAML tracer add-on to your web browser.

    MS Edge Chromium and Google Chrome users can install the application from the Chrome store.

    2. Go to: https://chromewebstore.google.com

    3. Search for "SAML tracer" in the search box

    4. Click on the "SAML-tracer" application

    5. Click the "Install" button to have the add-on installed

    6. Once the add-on is installed, launch it via the browser's "Extensions" menu

    7. Click "Extensions"

    8. Click on "SAML-Tracer"

    9. While SAML-tracer is open, try to launch and login to the SAML Application having issues

     

    10. Reproduce the issue then in SAML-tracer, click on the "Export" button to download and save the SAML Trace to your local machine

     

    11. Upload or e-Mail the SAML trace which was downloaded to the SecureAuth Support Team for review

     

     

    Special Considerations (optional as needed):  

    If there are multiple browser tabs open, SAML-tracer may be pulling information from all SAML enabled applications currently running. It is preferred that a single Browser is open with SAML-tracer to take a clean trace of the application needing debugging.

     

     

    SecureAuth Knowledge Base Articles provide information based on specific use cases and may not apply to all appliances or configurations. Be advised that these instructions could cause harm to the environment if not followed correctly or if they do not apply to the current use case.

    Customers are responsible for their own due diligence prior to utilizing this information and agree that SecureAuth is not liable for any issues caused by misconfiguration directly or indirectly related to SecureAuth products.

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