Unable to download SAML Metadata in the New Experience interface

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    Applies to:
  • SecureAuth Identity Platform
Deployment model:
  • Hybrid
  • Version Affected:  21.04 - 24.04

    Description:  
    When attempting to download the SAML Metadata within the New Experience interface, the process fails with the below error displayed in the Browser


    Cause:
     
    This is seen in all versions from 21.04 base through to 24.4.1, in both Cloud and Hybrid deployments
    The process to download the Metadata file via the New Experience is expecting an Issuer value to be present, when this is missing it causes the failure

     

    Resolution:  
    Most SAML configurations will require a value to be present within this Field as it links to the Service Providers EntityID (or similar).
    If there is no requirement to have a value in the Issuer field, at this point in time the only way to work around this is one of the two below options:
    1) Download the Metadata file from within the Advanced interface for the Realm, on the Post Authentication Tab

    2) If it does not cause problems with the Service Provider, add a value to the Issuer Field within the SAML Realm Properties (see below) and it will be possible to download the Metadata from the New Experience interface

     

    SecureAuth Knowledge Base Articles provide information based on specific use cases and may not apply to all appliances or configurations. Be advised that these instructions could cause harm to the environment if not followed correctly or if they do not apply to the current use case.

    Customers are responsible for their own due diligence prior to utilizing this information and agree that SecureAuth is not liable for any issues caused by misconfiguration directly or indirectly related to SecureAuth products.

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