OIDC Revoke Permissions screen

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    Applies to:
  • SecureAuth Identity Platform
  • Legacy SecureAuth IdP
Deployment model:
  • Cloud
  • Hybrid
  • On Premises
  • Version Affected:  All

    Description:  

    Users complain that they see the Revoke Permissions screen instead of the App after they login to an OIDC app.

    Cause:  

    The OIDC Query String is missing from the URL. This can happen when the session has timed out or if they User has gone directly to the realm without going to the App first.

     

    Resolution:  

    A quick workaround is to add the OIDC url to the Restart URL section of the Overview tab. However, this only fixes the issue for session timeout/clicking on restart . To fix user error, we'll need a URL Rewrite rule.

    1. Open IIS
    2. Go to the realm in question
    3. Click on URL Rewrite
    4. Add a blank rule
    5. Setup the rule based on the example screenshots.

    image (3).png

    image (5).png

     

    Special Considerations :  

    With this in place, the Users won't be able to get to the revoke permissions page.

     

     

    SecureAuth Knowledge Base Articles provide information based on specific use cases and may not apply to all appliances or configurations. Be advised that these instructions could cause harm to the environment if not followed correctly or if they do not apply to the current use case.

    Customers are responsible for their own due diligence prior to utilizing this information and agree that SecureAuth is not liable for any issues caused by misconfiguration directly or indirectly related to SecureAuth products.

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