Version Affected: All
Description:
This document is designed to help intergrate with Invicti
Cause:
Invicti requires the SAML assertion to be signed but not the SAML message.
Resolution:
1. Set the Connection Type to SP Initiated by Redirect
2. Set the User ID Profile Field to Email1 (where Email1 maps to the email you wish to use in Invicti)
3. Take the SAML 2.0 Service URL from the Invicti Admin console and enter this in the Assertion Consumer Service (ACS) field, for the application you're creating in SecureAuth
4. Set an IdP Issuer on the SecureAuth side and copy this into the IdP Identifier in the Invicti console
5. Set the Audience on the SecureAuth side to match the Identifier in the Invicti console
6. Enable "Sign SAML assertion" on the SecureAuth side.
7. In the Invicti console, set the SAML 2.0 Endpoint to match your SecureAuth URL and realm number.
Eg: HTTPS://idp.example.com/SecureAuth123/
SecureAuth Knowledge Base Articles provide information based on specific use cases and may not apply to all appliances or configurations. Be advised that these instructions could cause harm to the environment if not followed correctly or if they do not apply to the current use case.
Customers are responsible for their own due diligence prior to utilizing this information and agree that SecureAuth is not liable for any issues caused by misconfiguration directly or indirectly related to SecureAuth products.
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