SAML signing cert export format issue

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    Applies to:
  • SecureAuth Identity Platform
  • Legacy SecureAuth IdP
Deployment model:
  • Cloud
  • Hybrid
  • On Premises
  • Version Affected:  All

    Description:  

    After exporting the signing cert from the PostAuth tab of a SAML realm to import into an SP, the SP throws an "Invalid Cert" error. 

     

    Google G Suite is one such SP

     

    Cause:  

    The SP expects a different format to what the Admin Console exports as. 

     

    Resolution:  

    1. On the IdP, open up the Computer Certificate Console. Eg, Certlm.msc
    2. Drill into Personal and find the signing cert in here
    3. Right click and click All Tasks |  Export
    4. Select No, do not export the private key
    5. Select Base-64 encoded X.509 (.cer)
    6. Complete the rest of the export and then try using this certificate.

     

     

     

     

    SecureAuth Knowledge Base Articles provide information based on specific use cases and may not apply to all appliances or configurations. Be advised that these instructions could cause harm to the environment if not followed correctly or if they do not apply to the current use case.

    Customers are responsible for their own due diligence prior to utilizing this information and agree that SecureAuth is not liable for any issues caused by misconfiguration directly or indirectly related to SecureAuth products.

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