Identity Platform Dashboard - ERROR Unable to load Dashboard Error: Request failed with status code 500

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    Applies to:
  • SecureAuth Identity Platform
Deployment model:
  • Hybrid
  • Version Affected:  22.02+

    Description:  
    When opening the New Experience Dashboard you are presented with an Error stating
    'ERROR Unable to load Dashboard Error: Request failed with status code 500'


    Developer Tools will display the below errors under Console


    Cause:  
    This can be due to missing, or an incorrect version of, .Net (Core) or some Components of .Net (Core)
    https://docs.secureauth.com/2404/en/secureauth-compatibility-guide.html#required--net-versions

    1) Find out if the correct version of .Net (Core) is installed
    This can be achieved by running the below in a Powershell Console

    (dir (Get-Command dotnet).Path.Replace('dotnet.exe', 'shared\Microsoft.NETCore.App')).Name

    Example


    Or by looking at Add/Remove Programs
    Example

    Resolution:  
    1) Uninstall the current version of .Net (Core), if installed  -  It is important to uninstall the old version before installing the new version
    2) Go to the below location, download the 'Hosting Bundle' for the correct version of .Net (Core), based on the version of IdP, and install it.
    This will install the required files and/or install any missing .Net (Core) Components
    https://dotnet.microsoft.com/en-us/download/dotnet

    IdP Version and Net (Core) requirements
    19.07 to 21.04  -  .NET Core 2.1
    22.02 to 22.12  -  .NET Core 3.1
    23.07  -  .NET 6
    24.04  -  .NET 8


    Example (for IdP 22.02 and 22.12)


     

    SecureAuth Knowledge Base Articles provide information based on specific use cases and may not apply to all appliances or configurations. Be advised that these instructions could cause harm to the environment if not followed correctly or if they do not apply to the current use case.

    Customers are responsible for their own due diligence prior to utilizing this information and agree that SecureAuth is not liable for any issues caused by misconfiguration directly or indirectly related to SecureAuth products.

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