Error Retrieving Contact Information for realms using Webservice

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    Applies to:
  • SecureAuth Identity Platform
  • Legacy SecureAuth IdP
Deployment model:
  • Cloud
  • Hybrid
  • On Premises
  • Version Affected:  All

    Description:  

    When accessing realms that are using webservice, the user sees "Error Retrieving Contact Information" after entering his or her credentials. In the Debug log, the following error can be found:

    Message="ContextUser.GetUser: GetProfileProperties() exception:WebServiceProfileProvider.GetPropertyValues: Got error when connecting to Profile Web Service: The server was unable to process the request due to an internal error. For more information about the error, either turn on IncludeExceptionDetailInFaults (either from ServiceBehaviorAttribute or from the <serviceDebug> configuration behavior) on the server in order to send the exception information back to the client, or turn on tracing as per the Microsoft .NET Framework SDK documentation and inspect the server trace logs.

     

    Cause:  

    The webservice realm cannot decrypt the webservice password.

     

    Resolution:  

    Check the License Info cert to verify it has the necessary permissions for SecureAuth0Pool. Even if it already does, re-enter the webservice password and try authenticating into the realm again afterwards.

     

     

    SecureAuth Knowledge Base Articles provide information based on specific use cases and may not apply to all appliances or configurations. Be advised that these instructions could cause harm to the environment if not followed correctly or if they do not apply to the current use case.

    Customers are responsible for their own due diligence prior to utilizing this information and agree that SecureAuth is not liable for any issues caused by misconfiguration directly or indirectly related to SecureAuth products.

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