Realm is missing in Classic Experience but still visible in New Experience

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    Applies to:
  • SecureAuth Identity Platform
Deployment model:
  • Hybrid
  • Version Affected:  19.07.01+

    Description:  

    When browsing in the Classic Experience, a realm no longer shows up in the Admin Console but still does so in the New Experience. Upon reviewing the IIS and D:\Secureauth directories, the paths to the realm still exist and the web.config is still present as well. Attempting to decrypt or update the web.config does not resolve the issue either.

     

    Cause:  

    The web.config is likely malformed due to recent edits that may have occurred.

     

    Resolution:  

    Try navigating to the realm (e.g. FQDN/SecureAuth7) and if this fails, you will see an error, such as Internal Server Error - 500. IIS logs will also show the specific status code, such as 500.19.

    Open the problematic web.config in a text editor and providing it is in a decrypted state still, paste the contents into an XML decoder such as the following:

    https://codebeautify.org/xml-url-decoding

     

    This will analyze the XML and notify of where the problem lies, on the exact line(s) in the config. Upon correcting the problematic section(s), save the web.config and try navigating to the realm once more.

     

    Special Considerations (optional as needed):  

    Do not bring over a web.config from a different realm to the problematic one to swap out for testing. As New Experience realms reside in the cloud, tampering with the config in Classic will cause problems with the portion of the config that exists in the cloud.

     

     

    SecureAuth Knowledge Base Articles provide information based on specific use cases and may not apply to all appliances or configurations. Be advised that these instructions could cause harm to the environment if not followed correctly or if they do not apply to the current use case.

    Customers are responsible for their own due diligence prior to utilizing this information and agree that SecureAuth is not liable for any issues caused by misconfiguration directly or indirectly related to SecureAuth products.

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