"Login Failure Authorization grant or refresh token is invalid" error with Epic Haiku

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    Applies to:
  • SecureAuth Identity Platform
  • Legacy SecureAuth IdP
Deployment model:
  • Cloud
  • Hybrid
  • On Premises
  • Version Affected:  All

    Description:  

    When using the Epic Haiku application on either iOS or Android, users will see the following prompt:
    "Login Failure Authorization grant or refresh token is invalid"

    However, users are still able to successfully authenticate via MFA with SecureAuth.

     

    Cause:  

    The token from the Consent Storage Attribute is not being saved in the user profile's attribute (e.g. Aux ID 10), which may be in use with another profile property field (e.g. houseIdentifier for KB Questions), which is causing a conflict and will overwrite the attribute being used for the token.

     

    Resolution:  

    Ensure the attribute in use for the token is unique and not being shared with other profile property fields.

     

     

    SecureAuth Knowledge Base Articles provide information based on specific use cases and may not apply to all appliances or configurations. Be advised that these instructions could cause harm to the environment if not followed correctly or if they do not apply to the current use case.

    Customers are responsible for their own due diligence prior to utilizing this information and agree that SecureAuth is not liable for any issues caused by misconfiguration directly or indirectly related to SecureAuth products.

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