Version Affected: All
Description:
How to restore the correct case for Realm folders and IIS Apps
Cause:
Older versions of Filesync (4.0.13 and lower) created realms using lowercase names instead of retaining CamelCase e.g. secureauth123 instead of SecureAuth123.
This can cause problems with the Copy Utility in the SecureAuth Updater and problems as described in this article:
Resolution:
1. Take a snapshot/full backup of the IdP
2. Open PowerShell as Administrator
3. Stop the SecureAuth FileSync service
4. Run this command to rename the filesystem folders:
cd D:\SecureAuth; gci -Directory | ?{$_.name -cmatch "secureauth[0-9]{1,3}$"} | %{ren $_ "_$($_.name)"; ren "_$($_.name)" $_.name.replace('secureauth','SecureAuth')}
5. Run this command to rename the IIS Apps:
cd 'iis:\sites\default web site'; gci | ?{$_.name -cmatch "secureauth[0-9]{1,3}$"} | %{ren $_.name $_.name.replace('secureauth','SecureAuth')}
6. Start the SecureAuth FileSync service
Special Considerations:
The commands above require the IIS Administration module, so if not already imported run the following command first:
Import-Module WebAdministration
SecureAuth Knowledge Base Articles provide information based on specific use cases and may not apply to all appliances or configurations. Be advised that these instructions could cause harm to the environment if not followed correctly or if they do not apply to the current use case.
Customers are responsible for their own due diligence prior to utilizing this information and agree that SecureAuth is not liable for any issues caused by misconfiguration directly or indirectly related to SecureAuth products.
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