SecureAuth Idp Version affected: 9.0+
Description:
How to control when log files roll over and how many log files are retained
Cause:
The number of text log files retained in the Audit, Debug and Error folders may be excessive, fail to roll when desired or be inconsistent between realms.
Resolution:
1. Decrypt the web.config file(s) for the relevant realm(s) from the Admin console
2. Open each web.config file in a text editor and search for the following string:
<loggingConfiguration
3. You will see a section like this:
The highlighted lines control the text logging
4. Scroll horizontally to the end of these lines and the setting which control when the log file rolls (rollInterval) and how many log files are retained (maxArchivedFiles) can be seen:
5. Change as desired and Save.
6. Repeat Steps 2 through 5 as needed for remaining web.config files
6. Encrypt the web.config file(s).
Special Considerations:
Related Articles:
SecureAuth Knowledge Base Articles provide information based on specific use cases and may not apply to all appliances or configurations. Be advised that these instructions could cause harm to the environment if not followed correctly or if they do not apply to the current use case.
Customers are responsible for their own due diligence prior to utilizing this information and agree that SecureAuth is not liable for any issues caused by misconfiguration directly or indirectly related to SecureAuth products.
Comments
Please sign in to leave a comment.