Our documentation on integrating SecureAuth with Salesforce through SP initiated SAML can be found Here.
However, if you've already followed our documentation and are experiencing an issue where the SecureAuth realm page isn't showing up on your Salesforce login domain, please continue.
Description:
Visiting the SecureAuth realm, configured for SP initiated SAML to Salesforce, returns a default Salesforce login page instead of the expected SecureAuth realm login page.
Causes:
The "Authentication Configuration" setting for your Salesforce domain may not be properly set.
Resolution:
1. Login to your Salesforce domain account, setup for the SecureAuth realm, and click on the setup tab in the top right corner of the screen.
2. In the control panel to the left-hand side of the screen, under Administer, click the "Domain Management" tab and then click "My Domain".
3. Scroll down to the Authentication Configuration menu and check to see if the Authentication Service lists the name of the SAML Single Sign-On Setting created for your SP-initiated SecureAuth realm. If it does not, click the Edit button.
4. Under Authentication Service, check the check-box to the name of the SAML Single Sign-On Setting created for your SP-initiated SecureAuth realm, un-check "Login Page" and click Save.
5. Re-visit the SecureAuth realm and you should now see the proper SecureAuth login page
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