SQL Connection Failed - Keyword Not Supported

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    Applies to:
  • Legacy SecureAuth IdP
Deployment model:
  • On Premises
  • SecureAuth IdP Version affected: All

     

    Description:

    This documentation assists in fixing the error "connection failed: keyword not supported: 'x'", where x can be any character or value.

    Cause:

    The connection string for the SQL in the Data tab is being delimited by an undeclared keyword

    Resolution:

    Remove any extra semi-colons that are delimiting the values, characters, or keywords.

     

    1. This is the error window that pops up when trying to "Test Connection".


    2. Semi-colons are utilized in the SQL connection string to delimit the values being inputted.  In this case, the client's password to their SQL service account began with a semi-colon.
    3. To resolve, simply remove the extra semi-colon by changing the password to not contain that delimiting character!
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