Do not see user VPN IP addresses in logs when using Cisco VPN for remote access and SecureAuth as RADIUS server

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    Applies to:
  • Legacy SecureAuth IdP
Deployment model:
  • On Premises
  • SecureAuth IdP version affected: All

    Description:

    We are using Cisco VPN for remote access VPN and SecureAuth is being used as RADIUS server to Authenticate users . We do not see the VPN user IP addresses in logs. Instead logs show "127.0.0.1" IP address  as UserHostAddress. How do we get these IP address details in logs?

    Cause:

    Calling-Station-Id needed to be enabled and configured on VPN client side.

    Resolution:

    In order to see the VPN users IP addresses in the logs you need to enable and pass the Calling-Station-Id. This needs to be enabled on the VPN client side to pass it through RADIUS.  Nothing needs to be configured on the SecureAuth side.

    SecureAuth Knowledge Base Articles provide information based on specific use cases and may not apply to all appliances or configurations. Be advised that these instructions could cause harm to the environment if not followed correctly or if they do not apply to the current use case.
    Customers are responsible for their own due diligence prior to utilizing this information and agree that SecureAuth is not liable for any issues caused by misconfiguration directly or indirectly related to SecureAuth products.

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