FileSync Install Error - SecureAuth Appliance is a Primary Node

Follow
    Applies to:
  • Legacy SecureAuth IdP
Deployment model:
  • On Premises
  • SecureAuth version affected: All

    Description:

    Clients installed FileSync on a secondary server by accident.  Now they go to remove FileSync by uninstalling and deleting the folder from the SecureAuth folder, but when they run the FileSync replica installer, it still reports that this server is reporting as a primary node.

    Cause:

    There are some registry keys that are also added to that server once the initial FileSync is installed.

    Resolution:

    Go into the registry and delete said folder.

     

    1. This is the errors that you will see in the FileSync install and event viewer respectively.



    2. Once you see these errors and all FileSync services have been stopped, uninstalled, and deleted, then make way over to the registry by opening up regedit.exe.


    3. Once registry is open, please navigate to the follow key:
      HKEY_LOCAL_MACHINE\SOFTWARE\SecureAuth\FileSync


    4. Once there, you will see that NodeType is declared as PRIMARY.  Go ahead and delete this entire folder from the registry.  Now try to install the replica FileSync service and all should be good!
    0 out of 0 found this helpful

    Comments

    0 comments

    Please sign in to leave a comment.