Error Retrieving Contact Information when Authenticating

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    Applies to:
  • Legacy SecureAuth IdP
Deployment model:
  • On Premises
  • SecureAuth IdP Version affected: All

     

    Description:

    Users will see "Error Retrieving Contact Information" when authenticating to a realm.

     

    Cause:

    There may be several causes to this issue:

    1. The profile provider information is incorrect in the Data tab.
    2. The profile attributes are missing in the user's account.
    3. The service account is unable to pull the profile fields for the user.
    4. The profile fields are missing in the Data tab.

    Resolution:

    1. Reconfigure the profile provider connection string and click "Test Connection" to confirm the connection works.
    2. Use LDP.exe to manually pull the user's profile attributes to see if any fields are missing or if the service account is unable to pull the attributes. Make sure you bind as the service account.
    3. Use "Update WebConfig" to bring back the missing profile fields in the Data tab.
      Admin Panel > Tools > Update Web Config and click "Update Web Config"
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