Phone mask does not produce desired result

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    Applies to:
  • Legacy SecureAuth IdP
Deployment model:
  • On Premises
  • Affected Versions:8.2 and above

    Issue:

    I am trying to modify the default phone mask from showing 4 digits to 5, but it doesn't seem to want to switch. I've tried using xxx-xx1-2345 but it still shows 4 digits instead of 5.

    Cause:

    The mask should contain "n" for the digits that need to be shown.

     

    Resolution:

     

    1. Go to Multi-Factor Methods tab | Phone Settings | phone mask (Regex) 

    2. Enter x for digits that you do not want to get displayed and n for the digits in the users phone that you want to be displayed . Any dashes will always be brought over. 


    3. Note that the number of digits in the user's phone entry must match exactly. so for the above example in step 2, the users data must have exactly 10 digits (555)555-5555. You can add more than one regex value in the config to account for more use cases by delimiting them with a comma. To account for country code use cases, you must separate the country code values by a pike, |. So +1 123-456-7890 would be x|xxx-xxn-nnnn which would turn it into xxxx-xx6-7890
    so to put both these rules in the config. it would look like this xxx-xxn-nnnn,x|xxx-xxn-nnnn.

     

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