Version Affected: All
Description: The Content and Localization link under the overview tab is inaccessible and displays the error below.
Data at root level is invalid. Line1, postion1.
Cause:
There should not be any Hash files in the resource folder (D:\SecureAuth\SecureAuthX\Resource).
Resolution:
1. Open PowerShell in admin mode
2. (i) Run the PowerShell command to see the hash files from the resource folder of all realms.
$Realms = Get-ChildItem D:\SecureAuth -Directory | Where {$_.Name -match "SecureAuth[0-9]"}
Foreach ($Realm in $Realms)
{
$Realm = $Realm.Fullname;
GCI "$Realm\Resource" | Where {$_.extension -eq ".md5" -or $_.extension -eq ".sha1" -or $_.extension -eq ".sha256"} | Remove-Item -WhatIf
}
Run the PowerShell command to delete the hash files from the resource folder of all realms
$Realms = Get-ChildItem D:\SecureAuth -Directory | Where {$_.Name -match "SecureAuth[0-9]"}
Foreach ($Realm in $Realms)
{
$Realm = $Realm.Fullname;
GCI "$Realm\Resource" | Where {$_.extension -eq ".md5" -or $_.extension -eq ".sha1" -or $_.extension -eq ".sha256"} | Remove-Item -force
}
(ii) Run the PowerShell command to delete the hash files from a single realm
GCI "D:\SecureAuth\SecureAuth1\Resource" | Where {$_.extension -eq ".md5" -or $_.extension -eq ".sha1" -or $_.extension -eq ".sha256"} | Remove-Item –force
You would see the hash file removed from the resource folder of impacted realms.
3. Login to the Admin console and go to the Content and Localization link under the Overview tab. You would be able to access it.
SecureAuth Knowledge Base Articles provide information based on specific use cases and may not apply to all appliances or configurations. Be advised that these instructions could cause harm to the environment if not followed correctly or if they do not apply to the current use case.
Customers are responsible for their own due diligence prior to utilizing this information and agree that SecureAuth is not liable for any issues caused by misconfiguration directly or indirectly related to SecureAuth products.
Comments
Please sign in to leave a comment.