Device fingerprint with AnyConnect embedded browser

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    Applies to:
  • SecureAuth Identity Platform
  • Legacy SecureAuth IdP
Deployment model:
  • Cloud
  • Hybrid
  • On Premises
  • Version Affected:  All Versions

    Description:  

    AnyConnect embedded browser doesn't create device fingerprint.

     

    Cause:  

    The issue occurs when Public/Private Mode option on the workflow tab is changed from Public mode only or Public and Private modes to Private mode only and AnyConnect embedded browser contains SecureAuthLoginsecureauthXX=PUBLIC cookie.

     

    Resolution:  

    Rename C:\Users\__your_username___\AppData\Local\Cisco\Cisco AnyConnect Secure Mobility Client\EBWebView folder to force clear the cookies and and sign in to AnyConnect again to set only SecureAuthLoginsecureauthXX=PRIVATE cookie as fingerprints work with PRIVATE mode only.

     

    Special Considerations (optional as needed):  

    Renaming EBWebView folder clears out the cached passwords/permissions/cookies.

     

     

    SecureAuth Knowledge Base Articles provide information based on specific use cases and may not apply to all appliances or configurations. Be advised that these instructions could cause harm to the environment if not followed correctly or if they do not apply to the current use case.

    Customers are responsible for their own due diligence prior to utilizing this information and agree that SecureAuth is not liable for any issues caused by misconfiguration directly or indirectly related to SecureAuth products.

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