iPadOS Mobile Profiles Not Downloading Properly on Newer Versions

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    Applies to:
  • SecureAuth Identity Platform
  • Legacy SecureAuth IdP
Deployment model:
  • Cloud
  • Hybrid
  • On Premises
  • iPadOS Version Affected: 13.x and Newer

    Description:  

    When trying to download a mobile profile on the new versions of iPadOS, the SecureAuth page will give one of the following errors:

    "Unable to download the profile - 4-Please contact admin - Unable to contact the Certificate Authority (WSE 3.0 configuration is incorrect)"

    or

    “Safari could not install a profile due to an unknown error”

    Even if something appears on the mobile device, it will not include the necessary certificates to be used properly for applications such as a VPN.

    Cause:  

    Apple has changed the User Agent with the newer versions of iPadOS. The previous User Agent displayed as a MobileOS / iPad, but the newer versions now display as a MacOS User Agent as default.

     

    Resolution:  

    To workaround this, we need to change the iPadOS User Agent back to an MobileOS / iPad User Agent.

    1. On your iPad, Go to Settings > Safari > Request Desktop Website

    2. Turn off the All Websites setting

    3. Retry to download the mobile profile

    You should be able to successfully download the mobile profile now similar to earlier versions.

     

    SecureAuth will be addressing the iPadOS User Agent change in a hotfix or new release. As of now, there is no release date of this fix.

     

    SecureAuth Knowledge Base Articles provide information based on specific use cases and may not apply to all appliances or configurations. Be advised that these instructions could cause harm to the environment if not followed correctly or if they do not apply to the current use case.

    Customers are responsible for their own due diligence prior to utilizing this information and agree that SecureAuth is not liable for any issues caused by misconfiguration directly or indirectly related to SecureAuth products.

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