The New Experience Admin Console opens a blank white page: Bad Gateway

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    Applies to:
  • Legacy SecureAuth IdP
Deployment model:
  • Hybrid
  • On Premises
  • SecureAuth IdP Version Affected:  9.3,19.07

    Description:  

    The New Experience console only opens a white blank page, nothing else is rendered.  Opening the browser's Developer Tools Network tab shows a 502 Bad Gateway error:

    mceclip0.png

    Or if the HttpProxy rewrite rules have been changed to "Redirect" as per this article (https://support.secureauth.com/hc/en-us/articles/360029283112-New-Experience-Console-Blank-White-Page-Bad-Gateway) then an error 500 Internal Server error will be shown:

    mceclip3.png

     

    Cause:  

    Browsing directly to https://localhost/httpproxy/tatooine/assets/sa-components.min.css gives a more detailed error:

    mceclip4.png

    This is caused by non-standard authentication settings for the "Default Web Site" in IIS or the HttpProxy application in IIS, e.g. ASP.NET Impersonation is enabled.

     

    Resolution:  

    1. Open IIS Manager, click on "Default Web Site" in the left hand pane then "Authentication" in the middle pane:

     

    2. Ensure the authentication settings are set to the defaults as per the below:

     

    3. Repeat for the HttpProxy application:

    mceclip0.png

     

     

     

    SecureAuth Knowledge Base Articles provide information based on specific use cases and may not apply to all appliances or configurations. Be advised that these instructions could cause harm to the environment if not followed correctly or if they do not apply to the current use case.

    Customers are responsible for their own due diligence prior to utilizing this information and agree that SecureAuth is not liable for any issues caused by misconfiguration directly or indirectly related to SecureAuth products.

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