Knowledge Base

Support Policies

SA Backup Tool: Restore failing with "The syntax of the command is incorrect."

SecureAuth IdP Version affected: All

Description: When trying to restore from a backup with the SA Backup Tool. The restore fails and the Window closes without a message.

If you open an admin command prompt and run the tool from there, you'll get to see the error message "The syntax of the command is incorrect."


Cause: The password contains an unsupported character.


When creating a backup with the SABackupTool, only use one of the special characters that is listed in the example. Notice that ! is not listed. 



1. Start the Backup tool as Admin

2. Set a new password that doesn't use !

3. Use this to perform the restore.


Please note, most of the time the backup and restore tool is used for migrations when both servers are available. If you are not able to create a new backup as the original Server is down, raise a case with SecureAuth Support.



Defect EE-558 is Waiting for fix in a future release of SecureAuth IdP

SecureAuth Knowledge Base Articles provide information based on specific use cases and may not apply to all appliances or configurations. Be advised that these instructions could cause harm to the environment if not followed correctly or if they do not apply to the current use case.

Customers are responsible for their own due diligence prior to utilizing this information and agree that SecureAuth is not liable for any issues caused by misconfiguration directly or indirectly related to SecureAuth products.

Have more questions? Submit a request


Please sign in to leave a comment.