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Newly Created Realms Won't FileSync, Post Installation

SecureAuth version affected: All

Description:
After installing FileSync between two or more servers, users may encounter an error where newly created realms do not properly Synchronize.

Cause:
The file permission or share settings for new realms may not be properly calibrated for FileSync.


Resolution:

1) Create the new realm(s), to be synced, on all servers--primary and secondary.
(E.g. SecureAuth16, SecureAuth22, etc.)

2) Right click and run the Reset-File-Perms.bat as an Administrator, on all servers in the cluster--primary and secondary. Order does not matter.
If Reset-File-Perms prompts you for an account name, be sure to enter the local user account name that is associated with FileSync (e.g. svc-xxx-xxx).
D:\MFCApp_Bin\Extras\Reset-File-Perms.bat

**Note: Reset-File-Perms will require an IIS reset. As an alternative, our FileSync Helper tool can be used, which functions the same as Reset-File-Perms, but without the IIS reset.

3) Configure the new realm(s) from the primary server. This will update the web.config files for those realm(s) on primary server making them most current. By default FileSync checks for updates every 10 minutes, but that time can be reduced by altering the interval value in the FileSyncService.exe.config file (See step 3. of our FileSync Service Troubleshooting document).

4) Login to secondary server(s) and verify that the web.config files for all newly created realms have the same Date modified time-stamp as those--same files--found on the primary server.

 

 

If issue persists:
1) Open the Services console. Verify that SecureAuthFileSync Service is running on each secondary server. Start or Restart the service.



2) From all FileSynced servers, open the Computer Management console and go into
System Tools > Shared Folders > Shares
Verify that the newly created realm(s) is listed.

 

3) Go into the directory of new realm(E.g D:\Secureauth\SecureAuth16). Find the web.config file, right click it and go to Properties then click the Security tab. Check if the FileSync service account is listed with (Modify, Read & execute, Read, and Write) permissions. The account will be something like svc-XXXXX

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